Status
Get in touch
Back
Resolved
Updating Free Renewal
Completed 15 Apr at 07:00am HDT.
Affected services
4: Zero - Renewal Panel
Completed
Maintenance ended
Posted 15 Apr at 07:00am HDT.
Started
Updating free renewal page with Minecraft Plans
Posted 15 Apr at 06:45am HDT.